·
Everthings going back to normal.
Resolved
Identified
The issue has been identified, and we are working on a fix.
Investigating
Since 11:05, there has been a delay in the messages pages on the dashboard.